SolidProfessor Login Issues
Incident Report for SolidProfessor
Resolved
This incident has been resolved.
Posted Sep 25, 2023 - 16:26 UTC
Update
Our investigation revealed an unhealthy server in our server pool. The server was replaced and we're back up without further errors.
Posted Sep 25, 2023 - 16:01 UTC
Monitoring
At the moment, some customers may have difficulty using SolidProfessor. Our team is actively investigating the incident and will update you with more details as we have them.

While our platform team continues to investigate and work on a permanent solution, some of these troubleshooting steps may help temporarily.
- Clearing your cache/cookies - https://support.solidprofessor.com/hc/en-us/articles/13352105219863-How-to-Clear-your-Cache
- Using a new browser

At SolidProfessor, we’re committed to providing the best possible service and are working tirelessly to resolve this incident. If you have any questions, please don't hesitate to reach out to support@solidprofessor.com
Posted Sep 25, 2023 - 15:34 UTC