Missing Achievements
Incident Report for SolidProfessor
Resolved
This incident has been resolved.
Posted Feb 06, 2023 - 13:57 UTC
Investigating
At the moment, some customers may have difficulty viewing their achieved certificates on the achievements page in SolidProfessor. Our team is actively investigating this issue and will update you with more details as we have them.
Posted Jan 17, 2023 - 15:19 UTC