SolidProfessor Outage
Incident Report for SolidProfessor
Resolved
We have identified an issue with our firewall and load balancers not recognizing our SSL certs. This caused a "not secure" page to be displayed prior to login. we deeply apologize for the inconvenience.
Posted Mar 22, 2023 - 21:17 UTC
Update
At the moment, some customers may have difficulty using SolidProfessor. Our team is actively investigating the incident and will update you with more details as we have them.

At SolidProfessor, we’re committed to providing the best possible service and are working tirelessly to resolve this incident.
Posted Mar 22, 2023 - 20:08 UTC
Update
We are continuing to investigate this issue.
Posted Mar 22, 2023 - 20:06 UTC
Investigating
We are currently investigating this issue.
Posted Mar 22, 2023 - 20:06 UTC