Solid Professor Log-In issues.
Incident Report for SolidProfessor
Resolved
This issue should be resolved as of 7 PM PDT 3/25/2023
Posted Mar 27, 2023 - 12:26 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 24, 2023 - 20:38 UTC
Investigating
At the moment, some customers may have difficulty using SolidProfessor. Our team is actively investigating the incident and will update you with more details as we have them.

While our platform team continues to investigate and work on a permanent solution, some of these troubleshooting steps may help temporarily.
- Clearing your cache/cookies - https://support.solidprofessor.com/hc/en-us/articles/13352105219863-How-to-Clear-your-Cache
- Using a new browser

At SolidProfessor, we’re committed to providing the best possible service and are working tirelessly to resolve this incident.
Posted Mar 24, 2023 - 20:36 UTC