SolidProfessor Log-in Issues
Incident Report for SolidProfessor
Resolved
We have resolved the ongoing log in issue. Please follow these steps to clear your browser settings. This will alleviate any persistent issues you may still be experiencing.

Chrome:
1. On your computer, open Chrome.
2. At the top right, click More More.
3. Click More tools and then Clear browsing data.
4. Click Advanced
5. At the top, choose a time range, select All time.
6. Click the boxes next to "Browsing History", "Cookies and other site data", "Cached images and files", and "Site settings"
7. Click Clear data
8. Close all Chrome windows

FireFox
1. On your computer, open Firefox.
2. Click the menu button to open the menu panel.
3. Click History and select Clear Recent History.
4. Change the time range to everything.
5. Check all of the boxes
6. Click ok
7. Close all Firefox windows

Edge
1. On your computer, open Edge.
2. Select Settings and more > Settings > Privacy, search, and services .
3. Under Clear browsing data > Clear browsing data now, "select Browsing History", "cookies and other site data", and "Chached images and files".
4. Under Time range, choose all time.
5. Select Clear now.
6. Close all Edge windows
Posted Mar 23, 2023 - 19:21 UTC
Monitoring
A fix has been implemented, but for it to take effect please follow these steps and clear your browser cookies.

1.In your browser, copy and paste the following:
• In Edge: copy/paste this into the address bar: edge://settings/siteData
• In Chrome: copy/paste this into the address bar: chrome://settings/content/all
2. Use the search bar to find "solidprofessor" and make sure you delete all entries related to solidprofessor.com.
3. Log in to SolidProfessor.

We will continue to monitor, and if you are still having issues reach out to support@solidprofessor.com
Posted Mar 23, 2023 - 16:48 UTC
Update
We are continuing to investigate this issue.
Posted Mar 23, 2023 - 15:56 UTC
Investigating
At the moment, some customers may have difficulty using SolidProfessor. Our team is actively investigating the incident and will update you with more details as we have them.

At SolidProfessor, we’re committed to providing the best possible service and are working tirelessly to resolve this incident.
No components were marked as affected by this incident.
Posted Mar 23, 2023 - 15:56 UTC